Chuyển đến nội dung
Diễn đàn CADViet
Đăng nhập để thực hiện theo  
hhhhgggg

Bác Pro nào sửa cho em đoạn Lisp cái !

Các bài được khuyến nghị

Đây là đoạn Lisp thay lệnh PE với tham số J,

1.em muốn đưa thêm khoảng hở giữa các line bằng 50 vào. Có nghĩa là line nào cách nhau <=50 thì vẫn nối vào nhau.

2. Em muốn thay đổi là chọn đối tượng xong đánh lệnh chứ ko phải đánh lệnh xong mới chọn đối tượng. Có nghĩa em chọn các line sau đánh jj thì nó liền vào thành 1 Pline .

Bác pro nào sửa cho em với !!!

 

CODE

 

(defun c:jj()

(setq b (ssget))

(COMMAND "PEDIT" "M" b "" "j" "" "")

(princ)

)

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Đây là đoạn Lisp thay lệnh PE với tham số J,

1.em muốn đưa thêm khoảng hở giữa các line bằng 50 vào. Có nghĩa là line nào cách nhau

2. Em muốn thay đổi là chọn đối tượng xong đánh lệnh chứ ko phải đánh lệnh xong mới chọn đối tượng. Có nghĩa em chọn các line sau đánh jj thì nó liền vào thành 1 Pline .

Bác pro nào sửa cho em với !!!

 

CODE

 

(defun c:jj()

(setq b (ssget))

(COMMAND "PEDIT" "M" b "" "j" "" "")

(princ)

)

Đây bạn:

(defun c:jj()
(COMMAND "PEDIT" "M" "P" "" "Y" "j" "50" "")
(princ)
)

Bạn phải chọn Line trước bằng Grid thì nó mới chạy đấy nhé. Đối tượng là Line

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Đây bạn:

(defun c:jj()
(COMMAND "PEDIT" "M" "P" "" "Y" "j" "50" "")
(princ)
)

Bạn phải chọn Line trước bằng Grid thì nó mới chạy đấy nhé. Đối tượng là Line

ok ! Thanks bác tuệ nhiều nhé !

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
ok ! Thanks bác tuệ nhiều nhé !

Bác Tuệ xem sửa lại giúp em đoạn Code đó đi, nó chạy hay bị lỗi treo máy lắm và hay lỗi ko chạy được lắm ! huhu

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
ok ! Thanks bác tuệ nhiều nhé !

Bác Tuệ xem sửa lại giúp em đoạn Code đó đi, nó chạy hay bị lỗi treo máy lắm và hay lỗi ko chạy được lắm ! huhu

Sửa đây bạn :

(defun c:jj()
(setq ss (ssget "P"))
(if (null ss) (prompt "khong co doi tuong nao duoc chon")
(COMMAND "PEDIT" "M" ss "" "Y" "j" "50" "")
)
(princ)
)

ok ! Thanks bác tuệ nhiều nhé !

Chỉ cần tick thanks nhiều nhiều là OK :cheers:

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Sửa đây bạn :

(defun c:jj()
(setq ss (ssget "P"))
(if (null ss) (prompt "khong co doi tuong nao duoc chon")
(COMMAND "PEDIT" "M" ss "" "Y" "j" "50" "")
)
(princ)
)

 

Chỉ cần tick thanks nhiều nhiều là OK :cheers:

Bác Tuệ này làm sao rùi ấy ! Bác sửa lại cho em đi. cái Code bác vừa sửa chẳng chạy được ! Bác test thử sẽ thấy. huhuhu

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Bác Tuệ này làm sao rùi ấy ! Bác sửa lại cho em đi. cái Code bác vừa sửa chẳng chạy được ! Bác test thử sẽ thấy. huhuhu

Theo yêu cầu của bạn -> Chọn đối tượng trước bằng Grid -> sau đó đánh lệnh jj

Bạn phải chọn Line trước bằng Grid thì nó mới chạy đấy nhé. Đối tượng là Line

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Theo yêu cầu của bạn -> Chọn đối tượng trước bằng Grid -> sau đó đánh lệnh jj

em chọn Line trước rồi mà. chọn kiểu j nó cũng ko chạy. Với lại bác có thể mở rộng đối tượng lên là 1 cái là line và 1 cái là Pline mà vẫn nối vào nhau được ko ? Bác cứ Test kỹ júp em nhé. Tránh mất thời gian !

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
em chọn Line trước rồi mà. chọn kiểu j nó cũng ko chạy. Với lại bác có thể mở rộng đối tượng lên là 1 cái là line và 1 cái là Pline mà vẫn nối vào nhau được ko ? Bác cứ Test kỹ júp em nhé. Tránh mất thời gian !

 

Mình xin sửa cái lisp của bạn như sau, bạn test thử xem sao, mình test thếy ok.

 

(defun c:jj()

(setq ss (ssget "_i"))

(COMMAND ".PEDIT" "M" ss "" "Y" "J" "50" "")

)

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Mình xin sửa cái lisp của bạn như sau, bạn test thử xem sao, mình test thếy ok.

 

(defun c:jj()

(setq ss (ssget "_i"))

(COMMAND ".PEDIT" "M" ss "" "Y" "J" "50" "")

)

ok ! Mình mới chạy test sơ bộ thấy ok. Để dùng một thời gian xem nó có bị lỗi ko đã. Nếu lỗi thì mình sẽ nhờ bạn sửa lại júp mình nhé . Thanks !

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
ok ! Mình mới chạy test sơ bộ thấy ok. Để dùng một thời gian xem nó có bị lỗi ko đã. Nếu lỗi thì mình sẽ nhờ bạn sửa lại júp mình nhé . Thanks !

 

Chú ý là cái lisp trên chỉ chạy đc khi có ít nhất 1 trong các đối tượng đc chọn là line, nếu chỉ toàn là pline thì sẽ bi lỗi.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Tạo một tài khoản hoặc đăng nhập để nhận xét

Bạn cần phải là một thành viên để lại một bình luận

Tạo tài khoản

Đăng ký một tài khoản mới trong cộng đồng của chúng tôi. Điều đó dễ mà.

Đăng ký tài khoản mới

Đăng nhập

Bạn có sẵn sàng để tạo một tài khoản ? Đăng nhập tại đây.

Đăng nhập ngay

Đăng nhập để thực hiện theo  

×