Chuyển đến nội dung
Diễn đàn CADViet
trungvp88

Lỗi kì lạ khi dim kích thước trong layout

Các bài được khuyến nghị

Xin chào anh chị. Em mới làm công việc văn phòng nên sử dụng cad có 1 vấn đề như sau nhờ mọi người giúp đỡ: Em vẽ tỷ lệ 1-1 ở model rồi chuyển qua layout dim kích thước với tính năng ananotive. Mọi chuyện bình thường khi e dim từ layout1-layout4 nhưng khi em tạo layout5 thì có hiện tượng mỗi khi dim xong, save, đóng bản vẽ rồi mở lại thì lại thấy con số ghi kích thước nhân thêm với 150 (là tỷ lệ bản vẽ mà e đã đặt cho VIewport trong layout5). THành ra bây giờ sau khi mở đi mở lại vài lần con số kích thước đã tăng lên triệu, tỷ.... trong khi các layout kia vẫn bình thường không bị nhân với tỷ lệ bản vẽ. k hiểu đã xảy ra chuyện gì??Cảm ơn anh chị

http://www.cadviet.com/upfiles/3/120565_ket_cau_1_1_1.dwg

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Dùng ananotive đo trong Layout???
Như vậy theo mình hiểu thì 
 ananotive chẳng còn ý nghĩa. :mellow: 
Lỗi này chắc do tính năng Make dimentions associtive. Mỗi lần bạn Zoom hay chỉnh sửa Viewport thì Dim sẽ nhảy theo kích thước tỉ lệ khung Viewport.
 

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Dùng ananotive đo trong Layout???

Như vậy theo mình hiểu thì  ananotive chẳng còn ý nghĩa. :mellow: 

Lỗi này chắc do tính năng Make dimentions associtive. Mỗi lần bạn Zoom hay chỉnh sửa Viewport thì Dim sẽ nhảy theo kích thước tỉ lệ khung Viewport.

 

Ồ, đúng thế, bỗng dưng em mới để ý điều đó. Tại bấy lâu nay là em cứ đọc nhiều thứ quá nên ứng dụng chưa hợp lý. nếu ở layout thì Ananotive hay không thì cũng có ảnh hưởng gì đâu nhỉ?? Tuy nhiên đây k phải vấn đề bản vẽ của em. Em thử tạo 1 dim mới hoàn toàn k sử dụng ananotive thì vẫn bị hiện tượng như trên. Khi mở lại bản vẽ thì kích thước lại biến đổi từ 6000x150=900000. Và cũng k phải do biến dimassoc. Ôi muốn nổ tung đầu :(

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Bạn Dim1 -> Update hoặc -Dimstyle -> Apply  rồi chọn các dimension đấy. Lưu, tắt đi bật lại kiểm tra xem sao

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

nếu bạn thấy đã tìm ra phương pháp là không nên sử dụng annotative trong Layout mà theo cách nói của kotnguyen là "không có ý nghĩa gì nữa" thì theo minh bạn nên Dim lại hoàn toàn bên Model rồi MV lại bên layout đi, không cần đi sâu tìm hiểu sai xót nữa vì sau này sẽ không dùng phương pháp này nữa

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Bạn Dim1 -> Update hoặc -Dimstyle -> Apply  rồi chọn các dimension đấy. Lưu, tắt đi bật lại kiểm tra xem sao

Cám ơn anh! Em dùng cả 2 cách thì sau khi chọn object là các dim thì giá trị trở về đúng như khi em vẽ. Tuy nhiên sau đó save, đóng, mở lại thì lại vẫn bị hiện tượng như trên. ở layout 5 này, e k dùng lisp cutdim như ở các layout trước nữa mà thay vào đó sử dụng biến Fixed length extention lines để chân dim đều và biến dimspace để cố định khoảng cách 2 lớp dim.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

nếu bạn thấy đã tìm ra phương pháp là không nên sử dụng annotative trong Layout mà theo cách nói của kotnguyen là "không có ý nghĩa gì nữa" thì theo minh bạn nên Dim lại hoàn toàn bên Model rồi MV lại bên layout đi, không cần đi sâu tìm hiểu sai xót nữa vì sau này sẽ không dùng phương pháp này nữa

Cảm ơn anh đã quan tâm. Tất nhiên là em đã thử tạo 1 dim mà ko sử dụng ananotive và dim thử vào các mv ở các tỉ lệ khác nhau,và em thấy đúng là ko có sự khác biệt gì :D TRong chuyện này có điều gì đó chưa hiểu rõ hết. Mong anh chỉ giáo?

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Mình đã thử test, k thấy có dấu hiệu gì bất thường sau khi save bật lại. Bạn đang dùng CAD bao nhiêu, có load lisp nào không ?

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Mình đã thử test, k thấy có dấu hiệu gì bất thường sau khi save bật lại. Bạn đang dùng CAD bao nhiêu, có load lisp nào không ?

Cảm ơn bác ketxu đã test. Em chỉ dùng mỗi lisp cutdim. Tuy nhiên ở layout5 này em lại k dùng lisp cutdim theo 1 số lời khuyên trên diễn đàn mà thay vào đó em sử dụng biến dimfxlon và dimspace để làm cho chân dim đều. Tuy nhiên khi em gỡ lisp đó ra thì vẫn bị

hiện tượng như vậy. trước khi đóng bản vẽ:https://plus.google.com/photos/yourphotos?pid=6077475274865434050&oid=107388843358258807402

sau khi em mở lại bản vẽ:https://plus.google.com/photos/yourphotos?banner=pwa&pid=6077478426339043266&oid=107388843358258807402

 

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Tạo một tài khoản hoặc đăng nhập để nhận xét

Bạn cần phải là một thành viên để lại một bình luận

Tạo tài khoản

Đăng ký một tài khoản mới trong cộng đồng của chúng tôi. Điều đó dễ mà.

Đăng ký tài khoản mới

Đăng nhập

Bạn có sẵn sàng để tạo một tài khoản ? Đăng nhập tại đây.

Đăng nhập ngay


×