Đến nội dung


Hình ảnh

DRAWORDER


  • Please log in to reply
2 replies to this topic

#1 lamkts

lamkts

    Chưa sử dụng CAD

  • Members
  • Pip
  • 1 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 16 November 2009 - 03:36 PM

Có bạn nào giúp tôi với. Tôi dùng con laptop Hp, win vista có bản quyền. Vậy mà chương trình CAD 2007 của tôi lại bị lỗi mất lệnh DRAWORDER.
Lệnh này dùng để sắp xếp các đối ­tượng [Above objects/Under objects/Front/Back] :
Vậy mà tôi chỉ đưa được đối tượng từ đằng sau lên đằng trước(Front), không thể nào đưa đối tượng đằng trước ra đằng sau (Back) được .
Không biết lỗi này do đâu. Có phải do Win không?
  • 0

#2 Nguyen Hoanh

Nguyen Hoanh

    biết lệnh adcenter

  • Moderator
  • PipPipPipPipPipPipPip
  • 4106 Bài viết
Điểm đánh giá: 4495 (đỉnh cao)

Đã gửi 16 November 2009 - 06:44 PM

Có bạn nào giúp tôi với. Tôi dùng con laptop Hp, win vista có bản quyền. Vậy mà chương trình CAD 2007 của tôi lại bị lỗi mất lệnh DRAWORDER.
Lệnh này dùng để sắp xếp các đối ­tượng [Above objects/Under objects/Front/Back] :
Vậy mà tôi chỉ đưa được đối tượng từ đằng sau lên đằng trước(Front), không thể nào đưa đối tượng đằng trước ra đằng sau (Back) được .
Không biết lỗi này do đâu. Có phải do Win không?

Bạn có thể nói rõ là trường hợp 'không thể' của bạn được không?
- ACAD báo lỗi khi dùng tham số back
- ACAD vẫn thực hiện nhưng không chuyển về back -> Vì sao bạn biết nó chưa chuyển về back
  • 0

#3 RanMori

RanMori

    Chưa sử dụng CAD

  • Members
  • Pip
  • 3 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 01 July 2010 - 04:52 PM

Bạn có thể nói rõ là trường hợp 'không thể' của bạn được không?
- ACAD báo lỗi khi dùng tham số back
- ACAD vẫn thực hiện nhưng không chuyển về back -> Vì sao bạn biết nó chưa chuyển về back

Trường hợp của mình thì đở hơn. dùng Tool của Autocad thì tốt nhưng mình viết 1 ứng dụng VB6.0 chạy trên Autocad R14:
Chỉ đơn giản là load hình cad.dwg lên, trong hình có 1 HCN và mình chỉ chọn HCN từ ứng dụng và tô màu hatch cho HCN đó.
Nhưng tô xong thì HCN bị che bởi Hatch mới tạo rồi. Mình đã dùng thử lệnh SendCommand để gửi "DrawOrder" nhưng R14 không hỗ trợ.
Còn cách nào khác không?
Help me.
  • 0