Chuyển đến nội dung
Diễn đàn CADViet
  • Thông báo

    • Nguyen Hoanh

      CADViet đã hoàn tất nâng cấp   14/09/2017

      Chào các bạn, CADViet đã hoàn tất việc nâng cấp lên phiên bản mới. Tất cả các chức năng đã hoạt động theo kỳ vọng của ban quản trị. Nếu có vấn đề gì cần phản hồi, các bản post ở đây nhé: Trân trọng, Nguyễn Hoành.
Đăng nhập để thực hiện theo  
NguyenNgocSon

Vấn Đề Ghi Dữ Liệu Mở Rộng Xdata

Các bài được khuyến nghị

Chào các bác. Mình đang mắc vấn đề sau:

1. Đối tượng có chứa dữ liệu mở rộng Xdata được tạo và lưu bằng cad 2008

2. Sau khi mở bằng Cad 2015 (win10-64 bít) và lưu lại (.cad 2008). Xảy ra như sau:

- Nếu mở bằng Cad 2015 thì dữ liệu xdata vẫn còn tồn tại

- Nếu mở bằng Cad 2008 thì kiểm tra dữ liệu Xdata mất một phần

Bác nào gặp trường hợp này cho ý kiến

Cám ơn !

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Bạn có thể đưa bản vẽ lên cho anh em học hỏi và rút kinh nghiệm cụ thể không?

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Em xin gửi kèm dữ liệu chứa Xdata không lưu được

Mong bác nào đã gặp cho ý kiến giúp đỡ cám ơn !

Hình ảnh chụp khi có dữ liệu Xdata

File lưu lại không tra được dữ liệu Xdata

Tính năng upfile lỗi

các bác vui lòng tải theo link

http://www.mediafire.com/file/1t20998eym6b23p/Xdata.rar

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Doan Van Ha    2.680

Không lưu được là sao?

Tôi test:

(entget (car (entsel)) '("*"))

Select object: ((-1 . <Entity name: 7ef9eee8>) (0 . "LWPOLYLINE") (330 .

<Entity name: 7ef9acf8>) (5 . "1902D") (100 . "AcDbEntity") (67 . 0) (410 .

"Model") (8 . "DS-Tim duong") (100 . "AcDbPolyline") (90 . 5) (70 . 0) (43 .

0.3) (38 . 0.0) (39 . 0.0) (10 332.08 313.83) (40 . 0.3) (41 . 0.3) (42 . 0.0)

(10 387.831 252.285) (40 . 0.3) (41 . 0.3) (42 . 0.0) (10 422.675 306.137) (40

. 0.3) (41 . 0.3) (42 . 0.0) (10 483.194 265.839) (40 . 0.3) (41 . 0.3) (42 .

0.0) (10 595.429 316.761) (40 . 0.3) (41 . 0.3) (42 . 0.0) (210 0.0 0.0 1.0)

(-3 ("DS" (1000 . "BD") (1000 . "Tuyen 1"))))

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Không lưu được là sao?

Tôi test:

(entget (car (entsel)) '("*"))

Select object: ((-1 . <Entity name: 7ef9eee8>) (0 . "LWPOLYLINE") (330 .

<Entity name: 7ef9acf8>) (5 . "1902D") (100 . "AcDbEntity") (67 . 0) (410 .

"Model") (8 . "DS-Tim duong") (100 . "AcDbPolyline") (90 . 5) (70 . 0) (43 .

0.3) (38 . 0.0) (39 . 0.0) (10 332.08 313.83) (40 . 0.3) (41 . 0.3) (42 . 0.0)

(10 387.831 252.285) (40 . 0.3) (41 . 0.3) (42 . 0.0) (10 422.675 306.137) (40

. 0.3) (41 . 0.3) (42 . 0.0) (10 483.194 265.839) (40 . 0.3) (41 . 0.3) (42 .

0.0) (10 595.429 316.761) (40 . 0.3) (41 . 0.3) (42 . 0.0) (210 0.0 0.0 1.0)

(-3 ("DS" (1000 . "BD") (1000 . "Tuyen 1"))))

Cái này không rõ là lý do gì ???

Trước khi chưa đóng bản vẽ thì tra được bình thường

Sau khi lưu và mở lại thì có lúc được lúc không ?

XD Chon doi tuong can tra((DS (1000 . )))

cũng không hiểu lỗi do cad hay là như thế nào hay do bản vẽ lỗi ?

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Xin up lại video lỗi ghi dữ liệu Xdata

Em dùng lệnh để lưu lại Xdata => Khi bản vẽ mở lưu lại được

Sau khi đóng và mở lại dữ liệu lưu đã bị mất

Nếu bác Hà mở thấy dữ liệu thì có lẽ nào do Autocad của em bị lỗi ?

Mong các bác qua xem gúp

Cám ơn !

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Không biết có bác nào ghé qua test giúp em chưa a ?

Em đang gần hoàn thiện ứng dụng lại gặp lỗi củ chuối này

Để em biết là do virus hay là máy cài HĐH lỗi

Cám ơn !

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
dinhvantrang    65

Mình test trên Cad2014. 

Đã dùng lệnh XData nhưng không thấy thông tin gì cả. 

Dùng lệnh XDLIST thì được thông tin như hình dưới37575_untitled.png

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Đúng là 2 lỗi trên của 2 bác khá khác nhau mặc dù cùng 1 bản vẽ ?

Em cũng đang không hiểu là lỗi này do đâu?

@Dinhvantrang: như vậy là có dữ liệu Xdata

@Giabach: như vậy ko có xdata . Em test trên máy cũng lỗi như Bác

Mong các bác lại ghé qua cho ý kiến

Cám ơn !

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Doan Van Ha    2.680

Lệnh XDATA và XDLIST nằm trong file "Xdata.lsp" thuộc thư mục "Express".

File này edit theo mỗi đời Cad nên thông tin đưa ra khác nhau tùy đời Cad?

Liệu lời phán bừa trên có đúng chăng?

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Thực ra mình dùng 1 số lisp lấy thông tin dữ liệu xdata cũng ra kiêu như trên nghĩa là:

Tra được Xdata

Command: xd
Chon doi tuong can tra((DS (1000 . BD) (1000 . Tuyen1)))

Khi bản vẽ hiện hành thì tra được như trên. Khi đóng bản vẽ tra lại sẽ là như này?

Command: xd
Chon doi tuong can tra((DS (1000 . )))

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Tạo một tài khoản hoặc đăng nhập để nhận xét

Bạn cần phải là một thành viên để lại một bình luận

Tạo tài khoản

Đăng ký một tài khoản mới trong cộng đồng của chúng tôi. Điều đó dễ mà.

Đăng ký tài khoản mới

Đăng nhập

Bạn có sẵn sàng để tạo một tài khoản ? Đăng nhập tại đây.

Đăng nhập ngay

Đăng nhập để thực hiện theo  

×