Chuyển đến nội dung
Diễn đàn CADViet
  • Thông báo

    • Nguyen Hoanh

      CADViet đã hoàn tất nâng cấp   14/09/2017

      Chào các bạn, CADViet đã hoàn tất việc nâng cấp lên phiên bản mới. Tất cả các chức năng đã hoạt động theo kỳ vọng của ban quản trị. Nếu có vấn đề gì cần phản hồi, các bản post ở đây nhé: Trân trọng, Nguyễn Hoành.
Đăng nhập để thực hiện theo  
quochiephb

Lỗi khi chèn block chứa attribute

Các bài được khuyến nghị

quochiephb    0

Mọi người cho mình hỏi : khi mình chèn block có chứa attribute thì phần attribute nó không hiện ra được là sao nhỉ, khi mình vào edit block thì attribute vẫn hiện bình thường.mình thử tạo attribute và block mới cũng vậy, cũng không được.mọi người giúp mình xem như vậy là nó làm sao nhỉ.cái block đó mình sử dụng ở bảng vẽ khác vẫn được.chỉ có bảng vẽ này là không hiện ra được.block đó ở trong bản vẽ kèm theo.mọi người xem hộ mình nhé.cảm ơn.

 

http://www.cadviet.com/upfiles/3/va1fls00u..._revb2122_1.dwg

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
tucdrom    642
Mọi người cho mình hỏi : khi mình chèn block có chứa attribute thì phần attribute nó không hiện ra được là sao nhỉ, khi mình vào edit block thì attribute vẫn hiện bình thường.mình thử tạo attribute và block mới cũng vậy, cũng không được.mọi người giúp mình xem như vậy là nó làm sao nhỉ.cái block đó mình sử dụng ở bảng vẽ khác vẫn được.chỉ có bảng vẽ này là không hiện ra được.block đó ở trong bản vẽ kèm theo.mọi người xem hộ mình nhé.cảm ơn.

Bạn đặt lại biến ATTDISP về On xem sao.

Command:attdisp

Command: ATTDISP Enter attribute visibility setting [Normal/ON/OFF] <Normal>:On

Chúc thành công.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
gia_bach    1.442
Mọi người cho mình hỏi : khi mình chèn block có chứa attribute thì phần attribute nó không hiện ra được là sao nhỉ, khi mình vào edit block thì attribute vẫn hiện bình thường.mình thử tạo attribute và block mới cũng vậy, cũng không được.mọi người giúp mình xem như vậy là nó làm sao nhỉ.cái block đó mình sử dụng ở bảng vẽ khác vẫn được.chỉ có bảng vẽ này là không hiện ra được.block đó ở trong bản vẽ kèm theo.mọi người xem hộ mình nhé.cảm ơn.

 

http://www.cadviet.com/upfiles/3/va1fls00u..._revb2122_1.dwg

Trên file Cad của bạn có 7 Block attribute : AXIS, axis1, CD_TRAI, F1, F2, SEE DWG., TDKMEMVUNGANG.

Kiểm tra trên Cad 2010 các attribute hiển thị bình thuờng.

 

file CAD : http://www.cadviet.com/upfiles/3/va1fls00u..._revb2122_1.zip

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
nataca    553
Mọi người cho mình hỏi : khi mình chèn block có chứa attribute thì phần attribute nó không hiện ra được là sao nhỉ, khi mình vào edit block thì attribute vẫn hiện bình thường.mình thử tạo attribute và block mới cũng vậy, cũng không được.mọi người giúp mình xem như vậy là nó làm sao nhỉ.cái block đó mình sử dụng ở bảng vẽ khác vẫn được.chỉ có bảng vẽ này là không hiện ra được.block đó ở trong bản vẽ kèm theo.mọi người xem hộ mình nhé.cảm ơn.

 

http://www.cadviet.com/upfiles/3/va1fls00u..._revb2122_1.dwg

Dùng lệnh ATTSYNC cho Block nào không hiện xem sao. Hoặc dùng BATTMAN với lựa chọn SYNS ở hộp thoại

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
vodanhnxc    3

vẫn chưa được các bác ạ,cùng 1 bản vẽ mà mở trên cad 11 thì được còn mở trên cad 2008 thì lại không được,bác nào biết vào giúp em với thanks

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
quoctuan903    4

các bác cho em hỏi ké tí chút nha!

cái dynamic block có thuộc tính visibility, em cho nó 2 trường hợp nhìn, TH1 có chứa 1 attribute, TH2 cũng chứa attribute đó luôn nhưng nằm ở vị trí khác. tạo xong block đó, em chèn thử thì bước đầu thấy bình thường, tiếp, chọn chế độ hiện thị visibilty thứ 2 thì thấy cái attribute lúc thì không nhảy ra vị trí khác, lúc lại không xuất hiện. em đã thử làm trên nhiều máy khác nhau nhưng thấy vẫn không khác gì(loại trừ khả năng máy em bị lỗi), mong các bác chỉ giáo. em có gửi kèm file đó, coi hộ em nha!http://www.cadviet.com/upfiles/3/104723_test.dwg

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Detailing    278

các bác cho em hỏi ké tí chút nha!

cái dynamic block có thuộc tính visibility, em cho nó 2 trường hợp nhìn, TH1 có chứa 1 attribute, TH2 cũng chứa attribute đó luôn nhưng nằm ở vị trí khác. tạo xong block đó, em chèn thử thì bước đầu thấy bình thường, tiếp, chọn chế độ hiện thị visibilty thứ 2 thì thấy cái attribute lúc thì không nhảy ra vị trí khác, lúc lại không xuất hiện. em đã thử làm trên nhiều máy khác nhau nhưng thấy vẫn không khác gì(loại trừ khả năng máy em bị lỗi), mong các bác chỉ giáo. em có gửi kèm file đó, coi hộ em nha!http://www.cadviet.c...104723_test.dwg

2 cái attribute của bạn có "TAG" giống nhau nên khi visible CAD nó chẳng biết nên lấy cái nào?

chỉ cần sửa cái tag của 1 trong 2 cái attribute lại là ok. chú ý là insert block mới để test nha.

Goodluck!

  • Vote tăng 2

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
quoctuan903    4

2 cái attribute của bạn có "TAG" giống nhau nên khi visible CAD nó chẳng biết nên lấy cái nào?

chỉ cần sửa cái tag của 1 trong 2 cái attribute lại là ok. chú ý là insert block mới để test nha.

Goodluck!

Bác ah, em ngồi thử lại 1 lúc và nhận ra là trong block, các visibility khác nhau không được đặt attribute giống nhau, không thì kiểu gì cũng gặp hiện tượng em đã kể trên.

em in trên layout nên định chế cái block khung tên đủ các cỡ giấy, ngang dọc, thông tin nhập vào tự động bằng field và attribute. anh chàng scott-FIELD thì chẳng sao, thế mà attribute thì đá nhau tùm lum, nản!

các bác cho e xin ý kiến về cái block khung tên với ạ( cách sửa chữa hoặc làm cách khác)

cám ơn rất nhiều!

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Detailing    278

Bác ah, em ngồi thử lại 1 lúc và nhận ra là trong block, các visibility khác nhau không được đặt attribute giống nhau, không thì kiểu gì cũng gặp hiện tượng em đã kể trên.

em in trên layout nên định chế cái block khung tên đủ các cỡ giấy, ngang dọc, thông tin nhập vào tự động bằng field và attribute. anh chàng scott-FIELD thì chẳng sao, thế mà attribute thì đá nhau tùm lum, nản!

các bác cho e xin ý kiến về cái block khung tên với ạ( cách sửa chữa hoặc làm cách khác)

cám ơn rất nhiều!

Sử dụng drawing properties + Block Attribute (Field) tuy nhiên nó vẫn có vài nhược điểm. Nếu ko có nhược điểm thì mọi ng đã dùng nó hết rồi :D

Bạn dùng thử và nói nhược điểm cho mọi ng cùng thảo luận nha.

Good luck!

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
quoctuan903    4

nói thật e chưa nghĩ ra cách gì xử lý cái lộn xộn của attribute gây ra cho dynamic block(chỉ với tính năng visibility thôi nhé, chức năng khác như rotate, array, flip, scale.. vẫn ngon lành)

thế nên không dại cho attribute vào dyn.block!

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Tạo một tài khoản hoặc đăng nhập để nhận xét

Bạn cần phải là một thành viên để lại một bình luận

Tạo tài khoản

Đăng ký một tài khoản mới trong cộng đồng của chúng tôi. Điều đó dễ mà.

Đăng ký tài khoản mới

Đăng nhập

Bạn có sẵn sàng để tạo một tài khoản ? Đăng nhập tại đây.

Đăng nhập ngay

Đăng nhập để thực hiện theo  

×