Chuyển đến nội dung
Diễn đàn CADViet
Đăng nhập để thực hiện theo  
xgame

Một sự cố về DIM mong đc giúp đỡ

Các bài được khuyến nghị

Bên Model mình dùng lệnh Mline để vẽ đường song song với kích thước là 2000 (2m) nếu đo kích thước bên Model thì chính xác là 2000 nhưng khi chuyên sang layout (Paper Space) đo lại thì lại là 135.521 sai lệch quá nhiều so với kích thước mình nhập, mặc dù Scale Factor của DIM mình hoàn toàn không thay đổi và vẫn để giữ nguyên là 1.

File đây nhờ các pác xem giúp.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Bên Model mình dùng lệnh Mline để vẽ đường song song với kích thước là 2000 (2m) nếu đo kích thước bên Model thì chính xác là 2000 nhưng khi chuyên sang layout (Paper Space) đo lại thì lại là 135.521 sai lệch quá nhiều so với kích thước mình nhập, mặc dù Scale Factor của DIM mình hoàn toàn không thay đổi và vẫn để giữ nguyên là 1.

File đây nhờ các pác xem giúp.

Bên layout bạn phải zoom với tỷ lệ 1xp (tỷ lệ gốc) thì dim mới đúng kích thước chuẩn. Hiện tại tỷ lệ zoom của bạn đang là 0,677xp tương đương với tỷ lệ xấp xỉ 1/150 lên dim dùng dim 1/100 tất nhiên là sai rồi

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Bên Model mình dùng lệnh Mline để vẽ đường song song với kích thước là 2000 (2m) nếu đo kích thước bên Model thì chính xác là 2000 nhưng khi chuyên sang layout (Paper Space) đo lại thì lại là 135.521 sai lệch quá nhiều so với kích thước mình nhập, mặc dù Scale Factor của DIM mình hoàn toàn không thay đổi và vẫn để giữ nguyên là 1.

File đây nhờ các pác xem giúp.

 

Bạn chỉnh scale của viewport bằng 1 thì kết quả sẽ là 2000 thôi. Tuy nhiên đó chắc không phải điều bạn muốn. Để tạo DIM cho bên layout người ta phải set lại Scale factor của dim ấy cho phù hợp với tỷ lệ

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Bên Model mình dùng lệnh Mline để vẽ đường song song với kích thước là 2000 (2m) nếu đo kích thước bên Model thì chính xác là 2000 nhưng khi chuyên sang layout (Paper Space) đo lại thì lại là 135.521 sai lệch quá nhiều so với kích thước mình nhập, mặc dù Scale Factor của DIM mình hoàn toàn không thay đổi và vẫn để giữ nguyên là 1.

File đây nhờ các pác xem giúp.

Xem lại vấn đề tỷ lệ.

Theo mình, đây là 2 cách đo kích thuớc khác nhau!

Giống thế này nhé: khung viewport là 1 cái ống nhòm nhòm sang phòng bên cạnh(model). bạn lại đo kích thưcoc trong ống nhòm thì có chuẩn không? bạn hiểu ý không?

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Bạn chỉnh scale của viewport bằng 1 thì kết quả sẽ là 2000 thôi. Tuy nhiên đó chắc không phải điều bạn muốn. Để tạo DIM cho bên layout người ta phải set lại Scale factor của dim ấy cho phù hợp với tỷ lệ

Bình thường tôi vẫn vẽ bên Model, hoàn thiện (thêm khung tên, DIM, ghi chú...) bên layout mà không cần chỉnh scale factor của DIM (mặc định là 1) mà vẫn ổn chẳng sao cả. Tôi không thích cách đặt tỉ lệ cho từng DIM khác nhau vì như vậy đối với một bản vẽ lớn thì khá là phức tạp và khó quản lý.

Xem lại vấn đề tỷ lệ.

Theo mình, đây là 2 cách đo kích thuớc khác nhau!

Giống thế này nhé: khung viewport là 1 cái ống nhòm nhòm sang phòng bên cạnh(model). bạn lại đo kích thưcoc trong ống nhòm thì có chuẩn không? bạn hiểu ý không?

Tất nhiên là tôi hiểu ý bạn nói nhưng vấn đề của tôi không hẳn là như vậy, bởi lẽ vẫn trong file trên nếu bên Model tôi vẽ một line với kích thước cũng giống như trên là 2000 khi chuyển qua layout dùng DIM đo thì kích thước hoàn toàn đúng. Hai đối tượng có kích thước nhập vào là giống nhau nhưng khi đo trên layout thì lại khác nhau, với line thì chính xác còn mline thì không chính xác, mọi thiết lập về tỉ lệ zoom ko thay đổi. Bạn có thể load file trên về test thử coi.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Bên Model mình dùng lệnh Mline để vẽ đường song song với kích thước là 2000 (2m) nếu đo kích thước bên Model thì chính xác là 2000 nhưng khi chuyên sang layout (Paper Space) đo lại thì lại là 135.521 sai lệch quá nhiều so với kích thước mình nhập, mặc dù Scale Factor của DIM mình hoàn toàn không thay đổi và vẫn để giữ nguyên là 1.

File đây nhờ các pác xem giúp.

Cái này không phải sự cố mà bản chất của nó như vậy, bạn không thể làm gì hơn được, phải dùng cách khác thôi! Khi ghi dim cho mline, tính năng dimassoc bị vô hiệu hoá bởi chính... AutoDesk! Bạn vào properties của dim là thấy. Lý do thì bạn thử vẽ 1 mline gấp khúc và tự suy luận khắc hiểu.

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Cái này không phải sự cố mà bản chất của nó như vậy, bạn không thể làm gì hơn được, phải dùng cách khác thôi! Khi ghi dim cho mline, tính năng dimassoc bị vô hiệu hoá bởi chính... AutoDesk! Bạn vào properties của dim là thấy. Lý do thì bạn thử vẽ 1 mline gấp khúc và tự suy luận khắc hiểu.

Không hẳn vậy, trong một số bản vẽ khi tôi DIM cho line cũng bị hiện tượng "dimassoc=No" ,tức là tính năng dimassoc cũng bị vô hiệu hóa. Có cách nào để chỉnh "dimassoc=No" thành Yes không vậy pác

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Không hẳn vậy, trong một số bản vẽ khi tôi DIM cho line cũng bị hiện tượng "dimassoc=No" ,tức là tính năng dimassoc cũng bị vô hiệu hóa. Có cách nào để chỉnh "dimassoc=No" thành Yes không vậy pác

Điều này chỉ xảy ra khi có ai đó (có thể là trình lisp nào đó) làm thay đổi biến dimassoc. Bạn có thể thiết lập lại bằng cách gõ dimassoc, nhập 2.

Một dimension bị non-associative, bạn có thể tái lập bằng lệnh DimReAssociate

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Tạo một tài khoản hoặc đăng nhập để nhận xét

Bạn cần phải là một thành viên để lại một bình luận

Tạo tài khoản

Đăng ký một tài khoản mới trong cộng đồng của chúng tôi. Điều đó dễ mà.

Đăng ký tài khoản mới

Đăng nhập

Bạn có sẵn sàng để tạo một tài khoản ? Đăng nhập tại đây.

Đăng nhập ngay

Đăng nhập để thực hiện theo  

×