Chuyển đến nội dung
Diễn đàn CADViet
  • Thông báo

    • Nguyen Hoanh

      CADViet đã hoàn tất nâng cấp   14/09/2017

      Chào các bạn, CADViet đã hoàn tất việc nâng cấp lên phiên bản mới. Tất cả các chức năng đã hoạt động theo kỳ vọng của ban quản trị. Nếu có vấn đề gì cần phản hồi, các bản post ở đây nhé: Trân trọng, Nguyễn Hoành.
dgqcc

Lỗi insert block

Các bài được khuyến nghị

Nguyen Hoanh    4.524
Khi insert block các block bị giảm kích thước (bị giảm đều theo một hệ số nào đó)

Gúp tôi với!

bạn thử gõ INSUNITS ở dòng command rồi đặt về 0 xem sao.

  • Vote tăng 2

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
vanduong    536
Khi insert block các block bị giảm kích thước (bị giảm đều theo một hệ số nào đó)

Gúp tôi với!

-----------------

he hé

bạn Insert Wblock hay BLock ?

nếu Wblock thì tùy từng file mà có Dim khác nhau ? ---> zô sửa lại thôi

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
abc123    1

Do sử dụng block ké (người khác khi tạo luôn để inch) nen khi ins_block toan phai scale(25,4)Có cách nào hay hơn ko BÁC HOÀNH (insunits) mỗi lần bản vẽ khác đều phai insunits. Bác Hoanh làm như thế nào để như cad2004?

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Nguyen Hoanh    4.524
Do sử dụng block ké (người khác khi tạo luôn để inch) nen khi ins_block toan phai scale(25,4)Có cách nào hay hơn ko BÁC HOÀNH (insunits) mỗi lần bản vẽ khác đều phai insunits. Bác Hoanh làm như thế nào để như cad2004?

Bạn mở file acad.dwt ra rồi gõ insunits, sau đó save as lại vào acad.dwt.

  • Vote tăng 2

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
abc123    1

Bạn mở file acad.dwt ra rồi gõ insunits, sau đó save as lại vào acad.dwt.

Bác Hoành giúp đỡ tới cùng luôn đi bác,1con gian nan đi suốt

chưa tơi đích. em có thử thêm vài cách thủ công theo hướng Bac:

C:\Documents and Settings\Cao Ba An\Application Data\Autodesk\AutoCAD 2009\R17.2\enu\Recent\Save Drawing As\acad.dwt

C:\Documents and Settings\Cao Ba An\Application Data\Autodesk\AutoCAD 2009\R17.2\enu\Recent\select template\acad.dwt

copy file acad.dwt của C:\Program Files\AutoCAD 2004\UserDataCache\Template\acad.dwt

dán vào

C:\Documents and Settings\Cao Ba An\Application Data\Autodesk\AutoCAD 2009\R17.2\enu\Recent\Save Drawing As\acad.dwt

C:\Documents and Settings\Cao Ba An\Application Data\Autodesk\AutoCAD 2009\R17.2\enu\Recent\select template\acad.dwt

C:\Program Files\AutoCAD 2009\UserDataCache\Template\acad.dwt

Vẫn không thành

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
abc123    1

Khi open fille of type: dwt thấy file acad.dwt sau đó insunits 1-->0 save acad.dwt bây giờ lúc nào mở ra luôn ở 0

khi khởi động cad luôn mở file đó(đã add đường dẫn vào trong option\file\support file search) nhưng vẫn không được

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Nguyen Hoanh    4.524
Khi open fille of type: dwt thấy file acad.dwt sau đó insunits 1-->0 save acad.dwt bây giờ lúc nào mở ra luôn ở 0

khi khởi động cad luôn mở file đó(đã add đường dẫn vào trong option\file\support file search) nhưng vẫn không được

Sau khi chuyển insunits về 1, bạn có save as file đó về lại vào file acad.dwt mà bạn vừa mở không?

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
abc123    1

Khi save as hiện lên template option (description:Normal English (feet and inches) drawing template. Uses Color Dependent Plot Styles.) chon (measurement:metric..) va save all layer as reconciled. save all layer as unreconciled. Bác Hoành ơi thử tất cả không hơn

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Snowman    90
Do sử dụng block ké (người khác khi tạo luôn để inch) nen khi ins_block toan phai scale(25,4)Có cách nào hay hơn ko BÁC HOÀNH (insunits) mỗi lần bản vẽ khác đều phai insunits. Bác Hoanh làm như thế nào để như cad2004?

Có một cách để mặc định unit của bản vẽ là inche, đó là setting trong startup dialog box

Bạn vào Tools/options/ chọn tab system, trong mục general option, mục startup, chọn show startup dialog box -> aply /ok

Sau đó mở một bản vẽ mới, hộp thoại startup hiện ra, bạn chọn mục default setting là imperial (hệ đo lường Anh) - >OK ( biến INSUNIT sẽ đặt mặc định là 1.)

(Tiếp tục vào tools/option để gỡ bỏ startup dialog box đi)

 

Muốn đưa bản vẽ này vào template, bạn save nó vào thư mục

C:\Documents and Settings\Username\Local Settings\Application Data\Autodesk\AutoCAD 2007\R17.0\enu\Template

chứ ko phải \enu\Recent\ như bạn làm

Có một cách khác là bạn save vào thư mục bất kỳ rồi add đường dẫn để thư mục này trở thành nơi chứa template dwg cho CAD

Bạn làm thư hình dưới đây, thay vì đường dẫn mặc định của CAD, bạn xoá đi và browse tới folder của riêng bạn

Template.jpg

 

Thực ra tất cả những cách làm này ko giải quyết triệt để lỗi khi insert block :s_big: (có nghĩa là bạn ko nhất thiết phải làm những việc dài dòng như trên)

Vì các block do mỗi ng tạo ra lại có một ...unit riêng (chính là unit của bản vẽ khi tạo block, có thể là m, mm, inche, unitless ...) Do đó khi insert, cách nhanh nhất là gõ lệnh UN, đặt lại unit bản vẽ cho trùng với unit của block (muốn biết unit của block là gì thì chỉ việc open ra ..)

Cần chú ý: khi cả block và bản vẽ có unit là unitless, thì block sẽ được scale theo souce và taget unit đã được đặt trong options, tab user preferences, mục insertion scale

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Tạo một tài khoản hoặc đăng nhập để nhận xét

Bạn cần phải là một thành viên để lại một bình luận

Tạo tài khoản

Đăng ký một tài khoản mới trong cộng đồng của chúng tôi. Điều đó dễ mà.

Đăng ký tài khoản mới

Đăng nhập

Bạn có sẵn sàng để tạo một tài khoản ? Đăng nhập tại đây.

Đăng nhập ngay


×