Chuyển đến nội dung
Diễn đàn CADViet
  • Thông báo

    • Nguyen Hoanh

      CADViet đã hoàn tất nâng cấp   14/09/2017

      Chào các bạn, CADViet đã hoàn tất việc nâng cấp lên phiên bản mới. Tất cả các chức năng đã hoạt động theo kỳ vọng của ban quản trị. Nếu có vấn đề gì cần phản hồi, các bản post ở đây nhé: Trân trọng, Nguyễn Hoành.
Đăng nhập để thực hiện theo  
dung12789

cần giúp đỡ: không tính diện tích được

Các bài được khuyến nghị

phamthanhbinh    3.123

không hiểu tại sao mình không dùng lệnh "bo" để tính diện tích được, mình đã thử các cách rồi đều báo lỗi, hik.

Hề hề hề,

Nó báo lỗi gì???

??????

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
hoa dai nhan    51

không hiểu tại sao mình không dùng lệnh "bo" để tính diện tích được, mình đã thử các cách rồi đều báo lỗi, hik.file cua minh đây:http://www.cadviet.c..._drawing1_2.dwg

 

 

Mình vẫn dùng được lệnh này trên bản vẽ của bạn mà. Bạn check lại coi

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Hai_YenLang    150

không hiểu tại sao mình không dùng lệnh "bo" để tính diện tích được, mình đã thử các cách rồi đều báo lỗi, hik.file cua minh đây:http://www.cadviet.c..._drawing1_2.dwg

Bo được ngon lành mà!

Bác chịu khó cài đặt lại AutoCAD nhé!

Command:

Command: li LIST 1 found

 

REGION Layer: "0"

Space: Model space

Handle = 1ad

Area: 156.6641

Perimeter: 146.2196

Bounding Box: Lower Bound X = 14.7345 , Y = 29.7345 , Z = 0.0000

Upper Bound X = 85.7625 , Y = 37.6996 , Z = 0.0000

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
huypas113    11

Select objects:

LWPOLYLINE Layer: "0"

Space: Model space

Handle = 1ad

Closed

Constant width 0.0000

area 156.6641

perimeter 146.2196

 

at point X= 60.6623 Y= 36.4113 Z= 0.0000

at point X= 24.3893 Y= 37.4913 Z= 0.0000

at point X= 23.8862 Y= 37.6996 Z= 0.0000

bulge -0.0008

center X=-136.3546 Y= 506.2012 Z= 0.0000

radius 495.1473

start angle 289

end angle 289

at point X= 22.3725 Y= 37.1846 Z= 0.0000

bulge -0.0062

center X= -30.5252 Y= 192.4509 Z= 0.0000

radius 164.0298

start angle 289

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
phamthanhbinh    3.123

không ai giúp mình hết sao!

Hề hề hề,

Mình đã thử và đúng là mình cũng không dùng được với lệnh boundary. Tuy nhiên nếu chỉ để tính diện tích bạn có thể dùng lệnh region để tạo một region từ các lwpolyline này. Từ đó gõ Area sẽ có diện tích của region bạn ạ.

Tuy nhiên như vậy thì các lwpolyline sẽ bị thay thế bởi region và muốn phục hồi lại bạn chỉ cần undo là Ok bạn ạ.

Chúc bạn thành công.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Doan Van Ha    2.677

Chắc là CAD của bác bị lỗi rồi, em vẫn boundary được bình thường với cả 02 sự lựa chọn là Region và Polyline:

Khoan! Có 3 người đăng đàn, cộng thêm tôi nữa (không boundary được) là 4. Kết quả: 2 người bo được còn 2 người không, như vậy thì không thể nói cad bị lỗi.

Rất có thể nó phụ thuộc một biến nào đó mà chúng ta chưa biết. Tôi đau đầu vì câu hỏi này nhiều giờ mà vẫn chưa tìm ra.

Hy vọng ngày mai trời lại sáng!

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
phamthanhbinh    3.123

Chắc là CAD của bác bị lỗi rồi, em vẫn boundary được bình thường với cả 02 sự lựa chọn là Region và Polyline:

 

 

klkhyr01322.jpg

 

 

 

 

Hề hề hề,

Bác chơi cad bao nhiêu vậy cà??? Mình chuyên dùng CAD2004 nên có thể nó xìu hơn CAD của bác chăng???

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Hai_YenLang    150

Em dùng CAD 2011 bác Phamthanhbinh ạ!

 

@ bác Doan Van Ha:

Command: bo BOUNDARY

Pick internal point: Selecting everything...

Selecting everything visible...

Analyzing the selected data...

Analyzing internal islands...

Pick internal point:

BOUNDARY created 1 polyline

Command:

 

Command: bo BOUNDARY

Pick internal point: Selecting everything...

Selecting everything visible...

Analyzing the selected data...

Analyzing internal islands...

Pick internal point:

1 loop extracted.

1 Region created.

BOUNDARY created 1 region

Command:

 

Bosssss322.jpg

 

Đây là file đính kèm bác kiểm tra lại xem?

http://www.cadviet.c...04426_bo123.dwg

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Doan Van Ha    2.677

Em dùng CAD 2011 bác Phamthanhbinh ạ!

@ bác Doan Van Ha:

Đây là file đính kèm bác kiểm tra lại xem?

http://www.cadviet.c...04426_bo123.dwg

Vấn đề là chế độ cài đặt của bạn và tôi có thể khác nhau, nên dù đã thử trên bản vẽ bạn gởi thì tôi vẫn không BO được.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
phamthanhbinh    3.123

Em dùng CAD 2011 bác Phamthanhbinh ạ!

 

@ bác Doan Van Ha:

Command: bo BOUNDARY

Pick internal point: Selecting everything...

Selecting everything visible...

Analyzing the selected data...

Analyzing internal islands...

Pick internal point:

BOUNDARY created 1 polyline

Command:

 

Command: bo BOUNDARY

Pick internal point: Selecting everything...

Selecting everything visible...

Analyzing the selected data...

Analyzing internal islands...

Pick internal point:

1 loop extracted.

1 Region created.

BOUNDARY created 1 region

Command:

 

 

 

Đây là file đính kèm bác kiểm tra lại xem?

http://www.cadviet.c...04426_bo123.dwg

Hề hề hề,

Không biết bác ĐoanVanHa dùng CAD bao nhiêu, nhưng như vậy thì mình có thể yên tâm rằng Cad2004 của mình không có lỗi. Vì rằng mình region thì vẫn Ok và dùng hatch thì nó cũng vẫn nhận đường biên này. Chỉ duy có boundary thì nó lại không chịu chơi mà bảo rằng : Valid hatch boundary not found.

Nguyên nhân có lẽ do các polyline này có mã dxf 70 là 128 chăng (bị đứt quãng nên CAD2004 không nhận dạng được boundary).

Thế mới biết dùng CAd cùi thì công việc cũng cùi theo.

Hề hề hề

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Doan Van Ha    2.677

Cầu cứu!

Sẵn thấy nhiều bác đang online nên nhắc lại câu hỏi này để may ra có bác nào tìm ra nguyên nhân.

Đó là bản vẽ ở #1. Có 4 người test thì 2 người bo được, còn 2 người không.

Tôi đã vẽ các hình khác trong bản vẽ đó thì vẫn bo OK, nhưng nó thì chịu.

Thậm chí đổi các đối tượng đó về line bình thường cũng không bo được.

Mất hàng giờ tìm kiếm mà vẫn bó tay nên tức lắm!

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
phamthanhbinh    3.123

Cầu cứu!

Sẵn thấy nhiều bác đang online nên nhắc lại câu hỏi này để may ra có bác nào tìm ra nguyên nhân.

Đó là bản vẽ ở #1. Có 4 người test thì 2 người bo được, còn 2 người không.

Tôi đã vẽ các hình khác trong bản vẽ đó thì vẫn bo OK, nhưng nó thì chịu.

Thậm chí đổi các đối tượng đó về line bình thường cũng không bo được.

Mất hàng giờ tìm kiếm mà vẫn bó tay nên tức lắm!

Hề hề hề,

Bác ĐoanVanHa ơi, mình dùng Cad2004, khi dùng line hoặc pline, ồ lại cái hình đó thì nó bo ngon lành, còn để như vậy thì chịu chết bác ạ.

Với CAd2004 mình đã thử các option của lệnh này đều không thành công.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Tạo một tài khoản hoặc đăng nhập để nhận xét

Bạn cần phải là một thành viên để lại một bình luận

Tạo tài khoản

Đăng ký một tài khoản mới trong cộng đồng của chúng tôi. Điều đó dễ mà.

Đăng ký tài khoản mới

Đăng nhập

Bạn có sẵn sàng để tạo một tài khoản ? Đăng nhập tại đây.

Đăng nhập ngay

Đăng nhập để thực hiện theo  

×