Chuyển đến nội dung
Diễn đàn CADViet
Đăng nhập để thực hiện theo  
hhhhgggg

Lisp đổi Font cho Style, tại sao lỗi khi đổi sang font .VnHelvetlnsH

Các bài được khuyến nghị

(defun C:doifont()

(command ".-style" "Standard" ".VnHelvetlnsH" "" "" "" "" ""))

 

 

Đó là đoạn Code đổi font cho Style, khi đổi sang các font khác, ko phải font .VnHelvetlnsH thì lisp chạy tốt, nhưng khi đổi sang font .VnHelvetlnsH thì ko chạy được, báo lỗi Unknow command, bác Pro nào sửa giúp em với !

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
(defun C:doifont()

(command ".-style" "Standard" ".VnHelvetlnsH" "" "" "" "" ""))

Đó là đoạn Code đổi font cho Style, khi đổi sang các font khác, ko phải font .VnHelvetlnsH thì lisp chạy tốt, nhưng khi đổi sang font .VnHelvetlnsH thì ko chạy được, báo lỗi Unknow command, bác Pro nào sửa giúp em với !

Có thể bạn chưa cài font VnHelvetlnsH trên hệ thống?!

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
(defun C:doifont()

(command ".-style" "Standard" ".VnHelvetlnsH" "" "" "" "" ""))

Đó là đoạn Code đổi font cho Style, khi đổi sang các font khác, ko phải font .VnHelvetlnsH thì lisp chạy tốt, nhưng khi đổi sang font .VnHelvetlnsH thì ko chạy được, báo lỗi Unknow command, bác Pro nào sửa giúp em với !

Fonts của Widows thiếu font .VnHelvetlnsH .

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
(defun C:doifont()

(command ".-style" "Standard" ".VnHelvetlnsH" "" "" "" "" ""))

Đó là đoạn Code đổi font cho Style, khi đổi sang các font khác, ko phải font .VnHelvetlnsH thì lisp chạy tốt, nhưng khi đổi sang font .VnHelvetlnsH thì ko chạy được, báo lỗi Unknow command, bác Pro nào sửa giúp em với !

Đoạn Code của bạn được sửa lại như sau :

(defun C:doifont()
(command ".-style" "Standard" ".VnHelvetInsH Medium" "" "" "" "" "")
(princ)
)

Lần này thì chắc chắn thành công. Không tick thanks là giận đó.

Chúc thành công. :cheers:

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Cái đó ko phải Windown thiếu font, vì nó báo lỗi Unknown Command mà.

 

Bạn đánh lệnh "style" vào xem trong phần font name có font ".VnHelvetlnsH" chưa? không phải CAD su dụng tất cả các font của windows đâu. Nó báo lỗi unknown command là do tới phần .VnHelvetlnsH" bị lỗi nên lệnh bị ngưng ở đó và thoát ra ngoài , các dấu "" sau đó gây ra lỗi unknown command. Có phài có tới 5 dòng unknown command ứng với 5 dấu "" khong?

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Tạo một tài khoản hoặc đăng nhập để nhận xét

Bạn cần phải là một thành viên để lại một bình luận

Tạo tài khoản

Đăng ký một tài khoản mới trong cộng đồng của chúng tôi. Điều đó dễ mà.

Đăng ký tài khoản mới

Đăng nhập

Bạn có sẵn sàng để tạo một tài khoản ? Đăng nhập tại đây.

Đăng nhập ngay

Đăng nhập để thực hiện theo  

×