Chuyển đến nội dung
Diễn đàn CADViet
comeonnow

Lỗi font unicode khi gõ dấu trong Autocad 2018

Các bài được khuyến nghị

Tình hình là em sử dụng song song cad 2007 và cad2018, tuy nhiên cad 2018 lại bị lỗi font unicode khi gõ chữ có dấu (chỉ những chữ có dấu ngã, dấu nặng, dấu hỏi, dấu mũ ^)

 

Em đã tìm nhiều topic trong forums nhưng không thấy cách giải quyết, google trên web tiếng anh thì không thấy lỗi như này (do người ta viết không có dấu)
Capture.JPG.1e0c8017aad81f9af84f578f1a7b9a3a.JPG
Bác nào gặp rồi và xử lý được chỉ giúp em với

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
1 giờ} trướ}c, Danh Cong đã nói:

Thử đọc bài này. 

 

Em đọc bài đó rồi, font của em là font hệ thống Arial, Timenewromans.. nằm trong thư mục Fonts của win rồi mà. Em thử Tahoma thì không lỗi dấu, Arial, timenewromans thì lỗi... các font .shx thì không sao...

 

Tải nhiều font vào Fonts trong win thì có lẽ sẽ fix được nhưng em sợ nặng máy. Hơn nữa em cũng muốn rõ lỗi gì mà bị vậy

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Nhưng điểm quan trọng là font bị lỗi là font Unicode (Arial) nên là không biết thiếu như thế nào, bác nào có đủ font Arial chuẩn cho em xin với.

Vấn đề này trên forums cũng có 1 vài người hỏi nhưng chưa thấy có câu trả lời chính xác..Capture123.JPG.b843f362ddb6d3335cb4c3b468e4223a.JPG

 

 

Capture12.JPG

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Có 2 font bạn cần biết : 1 là font của Window, 2 là font của riêng phần mềm cad ( với các phiên bản cad khác nhau sẽ có sự khác nhau, 2007 khác với 2018)

Bạn đọc kỹ lại bài tôi đã gửi lúc trước có nói rồi.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
3 giờ trước, Danh Cong đã nói:

Có 2 font bạn cần biết : 1 là font của Window, 2 là font của riêng phần mềm cad ( với các phiên bản cad khác nhau sẽ có sự khác nhau, 2007 khác với 2018)

Bạn đọc kỹ lại bài tôi đã gửi lúc trước có nói rồi.


Cái đó em cũng biết sơ sơ...

Thư mục font CAD 2007 em chỉ copy font .shx 

Còn CAD 2018 sau khi cóp font của 2007, bị lỗi em tải về nhiều font khác mà cũng không có tác dụng.

 

Cái chính, em vẫn nhắc lại là font bị lỗi là Arial mà cái đó luôn theo kèm trong Windows rồi !!!

 

 

 

Capture23234.JPG

Capture234234.JPG

Capture555.JPG

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
2 phút trước, Dongc202 đã nói:

BÁc thay đổi bộ gõ trong unicode xem bị lỗi k :))

thay đổi là sao nhỉ? mình chỉ mở file ví dụ khung tên mà cũng lỗi, đâu phải do bộ gõ!

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Mở file mà bị lỗi là do thiếu font rồi. Kích vào text xem dùng font gì. Rồi tải về cài đặt thôi. Còn gõ chữ mà bị lỗi thì thay đổi chỗ unicode là tcvn.. hay vni.. cho mỗi kiểu font trong cad ấy

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
8 phút trước, Dongc202 đã nói:

Mở file mà bị lỗi là do thiếu font rồi. Kích vào text xem dùng font gì. Rồi tải về cài đặt thôi. Còn gõ chữ mà bị lỗi thì thay đổi chỗ unicode là tcvn.. hay vni.. cho mỗi kiểu font trong cad ấy

Tôi thử gõ bạn xem, font Arial, bảng mã Unicode

Capture66.JPG

Capture67.JPG

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
8 giờ trước, comeonnow đã nói:

Tôi thử gõ bạn xem, font Arial, bảng mã Unicode

Capture66.JPG

Capture67.JPG

 

Bạn gõ trong word, excel hoặc notepad rồi copy sau đó paste vào cad khi đang edit xem có bị lỗi không.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
13 giờ trước, congviet đã nói:

 

Bạn gõ trong word, excel hoặc notepad rồi copy sau đó paste vào cad khi đang edit xem có bị lỗi không.

Đúng! Copy vào thì không bị lỗi font!!! 

11 giờ trước, Dongc202 đã nói:

Tôi vẫn gõ chữ bình thường mà, quan trọng font chữ nào thì phải đúng với bảng mã đó thì gõ mới k bị lỗi

 

Cái vấn đề bảng mã tôi hiểu rõ mà, k phải do lỗi đó. Thực chất chả cần gõ gì cũng đc vì Text tôi dùng .shx, chỉ cần hiển thị khung tên chuẩn ko bị lỗi là được

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Vào lúc 8/1/2018 tại 22:01, comeonnow đã nói:

Đúng! Copy vào thì không bị lỗi font!!! 

Cái vấn đề bảng mã tôi hiểu rõ mà, k phải do lỗi đó. Thực chất chả cần gõ gì cũng đc vì Text tôi dùng .shx, chỉ cần hiển thị khung tên chuẩn ko bị lỗi là được

Trước tôi cũng bị như bạn copy text từ chương trình khác vào cad thì được mà cứ gõ trực tiếp trên cad thì bị lỗi chữ, mặc dù đã đủ font, và trên máy khác thì không bị lỗi. Nguyên nhân chính xác là gì thì tôi không rõ nhưng tôi làm như sau thì khắc phục được lỗi trên. Chỉ mất công thiết lập lại mấy cái addins thôi.

Solution:

Bạn vào Option (lệnh op) -> Profiles -> Reset (Nhớ Export cái profiles nhé tránh trường hợp reset xong vẫn bị lỗi thì import lại). 

  • Like 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
7 giờ trước, congviet đã nói:

Trước tôi cũng bị như bạn copy text từ chương trình khác vào cad thì được mà cứ gõ trực tiếp trên cad thì bị lỗi chữ, mặc dù đã đủ font, và trên máy khác thì không bị lỗi. Nguyên nhân chính xác là gì thì tôi không rõ nhưng tôi làm như sau thì khắc phục được lỗi trên. Chỉ mất công thiết lập lại mấy cái addins thôi.

Solution:

Bạn vào Option (lệnh op) -> Profiles -> Reset (Nhớ Export cái profiles nhé tránh trường hợp reset xong vẫn bị lỗi thì import lại). 

Tks bác, để em thử

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Vào lúc 1/10/2018 tại 14:32, congviet đã nói:

Trước tôi cũng bị như bạn copy text từ chương trình khác vào cad thì được mà cứ gõ trực tiếp trên cad thì bị lỗi chữ, mặc dù đã đủ font, và trên máy khác thì không bị lỗi. Nguyên nhân chính xác là gì thì tôi không rõ nhưng tôi làm như sau thì khắc phục được lỗi trên. Chỉ mất công thiết lập lại mấy cái addins thôi.

Solution:

Bạn vào Option (lệnh op) -> Profiles -> Reset (Nhớ Export cái profiles nhé tránh trường hợp reset xong vẫn bị lỗi thì import lại). 

tks bác, đúng là k bị nhưng có lúc bật lại lỗi font, tắt CAD bật lại lại hết...

8 giờ trước, cuongtk2 đã nói:

Bạn vào phần "Bảng điều khiển"  trong Unikey. Bỏ chọn "Luôn sử dụng clipboard cho unicode"

Thực ra k phải là gõ tiếng việt bị lỗi mà là lỗi font ở xref khung tên..

 

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

có thể... trong bảng text style, anh đã vô tình tích vào "Use bigfont". Phải bỏ cái tích này đi thì mới bình thường được.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Tạo một tài khoản hoặc đăng nhập để nhận xét

Bạn cần phải là một thành viên để lại một bình luận

Tạo tài khoản

Đăng ký một tài khoản mới trong cộng đồng của chúng tôi. Điều đó dễ mà.

Đăng ký tài khoản mới

Đăng nhập

Bạn có sẵn sàng để tạo một tài khoản ? Đăng nhập tại đây.

Đăng nhập ngay

×