Chuyển đến nội dung
Diễn đàn CADViet
Đăng nhập để thực hiện theo  
kadic309

Help lỗi error: bad argument type: stringp nil khi khởi động CAD

Các bài được khuyến nghị

Khi mình mở Cad 2007 thì báo lỗi như sau:

 

Customization file loaded successfully. Customization Group: ACAD

Customization file loaded successfully. Customization Group: CUSTOM

Customization file loaded successfully. Customization Group: EXPRESS

Regenerating model.

 

AutoCAD Express Tools Copyright © 2002-2004 Autodesk, Inc.

 

AutoCAD menu utilities loaded.; error: bad argument type: stringp nil

; error: bad argument type: stringp nil

Command: COMMANDLINE

 

Ai biết giải thích và chỉ cách khắc phục giùm. Thanks

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Khi mình mở Cad 2007 thì báo lỗi như sau:

 

Customization file loaded successfully. Customization Group: ACAD

Customization file loaded successfully. Customization Group: CUSTOM

Customization file loaded successfully. Customization Group: EXPRESS

Regenerating model.

 

AutoCAD Express Tools Copyright © 2002-2004 Autodesk, Inc.

 

AutoCAD menu utilities loaded.; error: bad argument type: stringp nil

; error: bad argument type: stringp nil

Command: COMMANDLINE

 

Ai biết giải thích và chỉ cách khắc phục giùm. Thanks

Có thể trong cad của bạn có load file lisp nào đó

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Mình gặp phải lỗi này: layon ; error: bad argument type: stringp nil.

Khi mình dùng lệnh layiso để giữ lại 1 layer, sau đó dùng lệnh layon thì báo lỗi trên. Có cách gì khắc phục không?

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Mình gặp phải lỗi này: layon ; error: bad argument type: stringp nil.

Khi mình dùng lệnh layiso để giữ lại 1 layer, sau đó dùng lệnh layon thì báo lỗi trên. Có cách gì khắc phục không?

Chắc chắn là do lisp bạn add vào bị sai về cấu trúc rồi, đây là một số lỗi của cấu trúc lisp mà Cad hiển thị

  • Unbound function: Hàm không có.
  • Bad function: Hàm sai.
  • Too many arguments: Thừa tham số.
  • Too few arguments: Thiếu tham số.
  • Misplaced close paren: Thừa dấu ngoặc đóng/ Thiếu dấu ngoặc mở.
  • EOF reached beore expression end: Thừa dấu ngoặc mở/ Thiếu dấu ngoặc đóng.
  • Not a number: Đối số của hàm phải là một số.
  • Bad argument type: Kiểu của tham số sai.
  • Như vậy lisp của bạn bị sai về kiểu tham số (kiểu như (car 3),...
  • Cách sửa một là bạn dùng lisp khác (lisp layon,,..) apps vào là được(hoặc đơn giản hơn dùng trực tiệp lệnh này của cad , đặt lại lệnh tắt là được)
  • hai là tìm tận nguồn file lisp đó tự sửa lại, hoặc up lên đây
  • có cùng mối quan tâm như bạn này http://www.cadviet.com/forum/index.php?showtopic=9547

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Tạo một tài khoản hoặc đăng nhập để nhận xét

Bạn cần phải là một thành viên để lại một bình luận

Tạo tài khoản

Đăng ký một tài khoản mới trong cộng đồng của chúng tôi. Điều đó dễ mà.

Đăng ký tài khoản mới

Đăng nhập

Bạn có sẵn sàng để tạo một tài khoản ? Đăng nhập tại đây.

Đăng nhập ngay

Đăng nhập để thực hiện theo  

×