Đến nội dung


Hình ảnh

Lệnh Copy (thắc mắc )


  • Please log in to reply
10 replies to this topic

#1 doan_kt

doan_kt

    biết pan

  • Members
  • Pip
  • 6 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 26 March 2010 - 02:18 AM

Trong lệnh coppy ấy sau khi mình kích chuột chọn điểm tới thì Cad nó kết thúc lệnh, như vậy mỗi lần mình chỉ coppy được 1 đối tượng ! Mình muốn cop nhiều đối tượng 1 lúc thì sửa thế nào các Bác nhi?
(thay đổi biến mặc định của Cad đang là Displacement thành Multiple )
Mình gặp hiện tượng này khi vừa cài lại Win và cài lại Cad (mà chỉ lần này mới bị )
Cám ơn các Bác noà chỉ giúp em nhé !
  • 0

#2 huyhuong

huyhuong

    biết vẽ circle

  • Members
  • PipPip
  • 35 Bài viết
Điểm đánh giá: 14 (tàm tạm)

Đã gửi 26 March 2010 - 07:32 AM

Trong lệnh coppy ấy sau khi mình kích chuột chọn điểm tới thì Cad nó kết thúc lệnh, như vậy mỗi lần mình chỉ coppy được 1 đối tượng ! Mình muốn cop nhiều đối tượng 1 lúc thì sửa thế nào các Bác nhi?
(thay đổi biến mặc định của Cad đang là Displacement thành Multiple )
Mình gặp hiện tượng này khi vừa cài lại Win và cài lại Cad (mà chỉ lần này mới bị )
Cám ơn các Bác noà chỉ giúp em nhé !


Bạn dùng lệnh Copym nhé.
  • 1

#3 doan_kt

doan_kt

    biết pan

  • Members
  • Pip
  • 6 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 26 March 2010 - 01:07 PM

Uh, cám ơn bạn ,Mình thường vào express/tool/command alias.. rồi sửa lệnh copy thành ""c""
Nhưng lần này mình cài lại Win và cad thì cài xong đã thấy ""c"" là lệnh copy rồi????????
khi đánh ""co"" hoặc ""copy"" thì ko bị lỗi như trên còn đánh ""c"" hoặc ""cp"" thì bị như trên
Mình muốn để lệnh tắt chỉ là ""c"" thôi nhưng nó cứ bị lỗi ??????
Bạn nào có cách triệt tận gốc ko? chỉ júp mình với !
  • 0

#4 master_worse

master_worse

    biết lệnh offset

  • Advance Member
  • PipPipPip
  • 170 Bài viết
Điểm đánh giá: 87 (tàm tạm)

Đã gửi 26 March 2010 - 02:35 PM

Uh, cám ơn bạn ,Mình thường vào express/tool/command alias.. rồi sửa lệnh copy thành ""c""
Nhưng lần này mình cài lại Win và cad thì cài xong đã thấy ""c"" là lệnh copy rồi????????
khi đánh ""co"" hoặc ""copy"" thì ko bị lỗi như trên còn đánh ""c"" hoặc ""cp"" thì bị như trên
Mình muốn để lệnh tắt chỉ là ""c"" thôi nhưng nó cứ bị lỗi ??????
Bạn nào có cách triệt tận gốc ko? chỉ júp mình với !


Vấn đề là có thể bạn đã load 1 file *.LSP nào đó có nội dung có dang (defun c:c () (command "copy"))
bạn bỏ nó đi và vào express/tool/command alias.. rồi sửa lệnh copy thành ""c""
  • 0

Ngu dốt không đáng thẹn bằng thiếu ý chí học hỏi


Tri thức làm người ta khiêm tốn, ngu si làm người ta kiêu ngạo (Ngạn ngữ Anh)


#5 doan_kt

doan_kt

    biết pan

  • Members
  • Pip
  • 6 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 26 March 2010 - 03:40 PM

Vấn đề là có thể bạn đã load 1 file *.LSP nào đó có nội dung có dang (defun c:c () (command "copy"))
bạn bỏ nó đi và vào express/tool/command alias.. rồi sửa lệnh copy thành ""c""

Mình chưa hơi đụng đến hay laod 1 lisp nào bạn a
  • 0

#6 Quang Duc Ha

Quang Duc Ha

    biết vẽ pline

  • Members
  • PipPip
  • 67 Bài viết
Điểm đánh giá: 7 (bình thường)

Đã gửi 26 March 2010 - 05:23 PM

Mình hiểu không biết có đúng ý bạn không. Bạn thử làm theo mình xem. Bạn vào option/section/ bỏ tích ở ô "use shiff to add to section" là ok.
  • 0

#7 Tue_NV

Tue_NV

    KS Võ Quang Tuệ

  • Moderator
  • PipPipPipPipPipPipPip
  • 4296 Bài viết
Điểm đánh giá: 3804 (đỉnh cao)

Đã gửi 26 March 2010 - 05:46 PM

Trong lệnh coppy ấy sau khi mình kích chuột chọn điểm tới thì Cad nó kết thúc lệnh, như vậy mỗi lần mình chỉ coppy được 1 đối tượng ! Mình muốn cop nhiều đối tượng 1 lúc thì sửa thế nào các Bác nhi?
(thay đổi biến mặc định của Cad đang là Displacement thành Multiple )
Mình gặp hiện tượng này khi vừa cài lại Win và cài lại Cad (mà chỉ lần này mới bị )
Cám ơn các Bác noà chỉ giúp em nhé !

Bạn thiết lập biến hệ thống Copymode với giá trị bằng 0

Command: copymode
Enter new value for COPYMODE <1>: 0

0 : Sets the COPY command to repeat automatically

1 : Sets the COPY command to create a single copy
  • 0

#8 Quang Duc Ha

Quang Duc Ha

    biết vẽ pline

  • Members
  • PipPip
  • 67 Bài viết
Điểm đánh giá: 7 (bình thường)

Đã gửi 26 March 2010 - 06:31 PM

Bac Tue còn đấy không cho em hỏi, làm như em có được không
  • 0

#9 hanhgl

hanhgl

    biết lệnh rotate

  • Members
  • PipPipPip
  • 133 Bài viết
Điểm đánh giá: 79 (tàm tạm)

Đã gửi 26 March 2010 - 09:34 PM

Trong lệnh coppy ấy sau khi mình kích chuột chọn điểm tới thì Cad nó kết thúc lệnh, như vậy mỗi lần mình chỉ coppy được 1 đối tượng ! Mình muốn cop nhiều đối tượng 1 lúc thì sửa thế nào các Bác nhi?
(thay đổi biến mặc định của Cad đang là Displacement thành Multiple )
Mình gặp hiện tượng này khi vừa cài lại Win và cài lại Cad (mà chỉ lần này mới bị )
Cám ơn các Bác noà chỉ giúp em nhé !

Anh dùng cad nào? Từ 2007 đã có lệnh copy liên tục ... chắc do lỗi Win
  • 0

#10 Tue_NV

Tue_NV

    KS Võ Quang Tuệ

  • Moderator
  • PipPipPipPipPipPipPip
  • 4296 Bài viết
Điểm đánh giá: 3804 (đỉnh cao)

Đã gửi 27 March 2010 - 06:45 AM

Anh dùng cad nào? Từ 2007 đã có lệnh copy liên tục ... chắc do lỗi Win

Chào bạn hanhgl
Copy liên tục chỉ khi biến hệ thống copymode đang được thiết lập bằng 0
Copy tạo thành a single copy khi biến hệ thống copymode đang ở giá trị bằng 1.

Bạn thiết lập biến hệ thống Copymode với giá trị bằng 0

Command: copymode
Enter new value for COPYMODE <1>: 0

0 : Sets the COPY command to repeat automatically

1 : Sets the COPY command to create a single copy


Chào bạn Quang Duc Ha

Mình hiểu không biết có đúng ý bạn không. Bạn thử làm theo mình xem. Bạn vào option/section/ bỏ tích ở ô "use shiff to add to section" là ok.

Bac Tue còn đấy không cho em hỏi, làm như em có được không

--> Việc làm như của bạn tức là đang điều khiển việc lựa chọn thêm đối tượng
Bạn vào option/section/ bỏ tích ở ô "use shiff to add to section" <=> với biến hệ thống Pickadd đang ở giá trị bằng 0 : Tức là việc điều khiển việc lựa chọn thêm đối tượng không cần sử dụng phím Shift (do bạn đã bỏ)

Còn nếu tick vào ô "use shiff to add to section" [/b][/i] <=> với biến hệ thống Pickadd đang ở giá trị bằng 1 : Tức là việc điều khiển việc lựa chọn thêm đối tượng phải sử dụng phím Shift (tức là muốn chọn thêm đối tượng nào phải giữ phím Shift)

Còn bạn hỏi mình làm như bạn có được không?
-> Không phù hợp với câu hỏi của bạn doan_kt vì bạn ấy không đề cập đến việc chọn đối tượng mà nói rằng khi thực hiện lệnh Copy xong chỉ tạo thành 1 a single copy mà thôi. Mong bạn hiểu.

Chúc 1 ngày mới tốt lành
  • 3

#11 Quang Duc Ha

Quang Duc Ha

    biết vẽ pline

  • Members
  • PipPip
  • 67 Bài viết
Điểm đánh giá: 7 (bình thường)

Đã gửi 27 March 2010 - 11:11 AM

Em cám ơn bác Tue NV đã hướng dẫn cho bọn em rất nhiệt tình. Chúc bác luôn khỏe để trả lời được hết những vướng mắc của bọn em! Em có câu hỏi trên diễn đàn mà chưa ai trả lời được (copy theo bắt điểm không được). Bác giúp em với! Mặc dù không ảnh hưởng lớn, nhưng khi vẽ cũng hơi khó chịu.
  • 0