Đến nội dung


Hình ảnh

Tiếng Việt trong AutoCAD


  • Please log in to reply
139 replies to this topic

#81 meohoang

meohoang

    biết lệnh adcenter

  • Members
  • PipPipPipPipPipPipPip
  • 811 Bài viết
Điểm đánh giá: 342 (khá)

Đã gửi 04 October 2008 - 09:35 PM

em dang dung` cad 2009 ,nhưng dùng font romans.shx ,big font univn.shx thì ko hiển thị đc TV. với cad 07 thì vẫn hiển thị bt.xin hỏi có cách nào khắc phục ko??
mong mọi người chỉ jùm

Thì bạn chuyển sang dùng font thường tiếng Việt như VNI-Helveconense hay .VnantH in bản vẽ mượt mà chủ đầu tư có khó tính vẫn mê mà
  • 0

#82 sonic

sonic

    Chưa sử dụng CAD

  • Members
  • Pip
  • 3 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 04 October 2008 - 10:54 PM

Thì bạn chuyển sang dùng font thường tiếng Việt như VNI-Helveconense hay .VnantH in bản vẽ mượt mà chủ đầu tư có khó tính vẫn mê mà


tất nhiên minh` vẫn dùng font khác viết đc TV.Vì cad 07 dung font đấy vẫn tốt mà sang cad 09 lại lỗi tùm lum nên mới hỏi thui :cheers:
  • 0

#83 duccamranh

duccamranh

    biết zoom

  • Members
  • Pip
  • 17 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 10 October 2008 - 04:02 PM

_Mình có 1 bản vẽ ko hiện được tiếng Việt,khi mở bản vẽ có dòng thông báo như sau:" substituting(simplex.shx) for (VNI_Avo).Regenerating model". Dòng thông báo đó nghĩa là thế nào vậy các bác,tui tìm font "simplex.shx" chép vào máy rồi mà vẫn ko được.Mong các bác giúp đỡ!
  • 0

#84 meohoang

meohoang

    biết lệnh adcenter

  • Members
  • PipPipPipPipPipPipPip
  • 811 Bài viết
Điểm đánh giá: 342 (khá)

Đã gửi 10 October 2008 - 07:40 PM

_Mình có 1 bản vẽ ko hiện được tiếng Việt,khi mở bản vẽ có dòng thông báo như sau:" substituting(simplex.shx) for (VNI_Avo).Regenerating model". Dòng thông báo đó nghĩa là thế nào vậy các bác,tui tìm font "simplex.shx" chép vào máy rồi mà vẫn ko được.Mong các bác giúp đỡ!

Vào đây down các loại font *.shx này về ; cả 1 kho luôn
http://www.cadviet.c...ho_AutoCAD.html
  • 0

#85 maithanhluan

maithanhluan

    Chưa sử dụng CAD

  • Members
  • Pip
  • 1 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 12 October 2008 - 01:11 PM

Em dùng Cad 2005 nhưng tự nhiên không gõ được chữ " ư ", mặc dù cài lại mà vẫn thế, nếu dùng Cad R14 thì vẫn gõ được bình thường. Mong các huynh chỉ giùm! Thanks!
  • 0

#86 nhatha

nhatha

    biết vẽ rectang

  • Members
  • PipPip
  • 85 Bài viết
Điểm đánh giá: 33 (tàm tạm)

Đã gửi 03 November 2008 - 07:49 AM

Em dùng Cad 2005 nhưng tự nhiên không gõ được chữ " ư ", mặc dù cài lại mà vẫn thế, nếu dùng Cad R14 thì vẫn gõ được bình thường. Mong các huynh chỉ giùm! Thanks!

bác chép mấy font chữ của Cad vào, sau đó sữ dụng Unikey và chuyển chế độ gõ chữ trên Cad là Time newromad hoặc Tahoma thì sẽ gõ được mà..-_-
  • 0

#87 g7canada

g7canada

    Chưa sử dụng CAD

  • Members
  • Pip
  • 4 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 08 December 2008 - 08:09 PM

Đây là 1 file dwg để test tiếng Việt, bạn thử mở xem đọc được mấy font?
http://www.cadviet.c.../cvtestfont.zip
Hình đã gửi

Nếu bạn chưa cài đủ các font, bạn có thể download nó trên CADViet, tại:
http://www.cadviet.c.../cvshx_font.zip : font CAD dạng shx
http://www.cadviet.c...files/TCVN3.zip : font hệ thống dạng ttf

Nếu bạn đã cài đủ font, bạn thử xem lại mã font bạn gõ vào đúng chưa? ví dụ khi bạn sử dụng font .vnArialH, bạn phải chọn mã font là TCVN-3 tại chương trình bộ gõ (VietKey, Unikey).


Nhờ anh em xem giúp mình với, mình cài đặt hết font rồi mở file test: CVTESTFONT.DWG lên xem thì thấy hiện đầy đủ chữ tiếng việt, mình chọn các style có sẵn trong file test để gõ thử chữ tiếng việt thì có style gõ được hết, có style cứ gõ một số chữ thì font tự động nhảy sang font khác. VD: style 2 mình để vietkey: unicode & engin2 rồi như mà gõ chứ đ thì toàn bị nhảy sang font arial thôi.
  • 0

#88 khanhduy

khanhduy

    biết vẽ arc

  • Members
  • PipPip
  • 45 Bài viết
Điểm đánh giá: -70 (yếu)

Đã gửi 20 December 2008 - 12:03 PM

[quote name='g7canada' date='Dec 8 2008, 20:09' post='43964']
Nhờ anh em xem giúp mình với, mình cài đặt hết font rồi mở file test: CVTESTFONT.DWG lên xem thì thấy hiện đầy đủ chữ tiếng việt, mình chọn các style có sẵn trong file test để gõ thử chữ tiếng việt thì có style gõ được hết, có style cứ gõ một số chữ thì font tự động nhảy sang font khác. VD: style 2 mình để vietkey: unicode & engin2 rồi như mà gõ chứ đ thì toàn bị nhảy sang font arial thôi.
[/quoteac
Các bác trả lời hộ bạn ý đi.em cũng tình trạng tương tự như thế này. :cheers:
  • 0

#89 Tue_NV

Tue_NV

    KS Võ Quang Tuệ

  • Moderator
  • PipPipPipPipPipPipPip
  • 4296 Bài viết
Điểm đánh giá: 3805 (đỉnh cao)

Đã gửi 20 December 2008 - 01:57 PM

Nhờ anh em xem giúp mình với, mình cài đặt hết font rồi mở file test: CVTESTFONT.DWG lên xem thì thấy hiện đầy đủ chữ tiếng việt, mình chọn các style có sẵn trong file test để gõ thử chữ tiếng việt thì có style gõ được hết, có style cứ gõ một số chữ thì font tự động nhảy sang font khác. VD: style 2 mình để vietkey: unicode & engin2 rồi như mà gõ chứ đ thì toàn bị nhảy sang font arial thôi.

Bạn có thể upload file CVTESTFONT.DWG lên diễn đàn được không?
  • 0

#90 giaptk3

giaptk3

    biết vẽ pline

  • Members
  • PipPip
  • 64 Bài viết
Điểm đánh giá: 13 (tàm tạm)

Đã gửi 20 December 2008 - 03:28 PM

Em dùng Cad 2005 nhưng tự nhiên không gõ được chữ " ư ", mặc dù cài lại mà vẫn thế, nếu dùng Cad R14 thì vẫn gõ được bình thường. Mong các huynh chỉ giùm! Thanks!

bạn bật nút Caps lock là được
  • 0

#91 levanduy

levanduy

    biết lệnh offset

  • Members
  • PipPipPip
  • 176 Bài viết
Điểm đánh giá: 73 (tàm tạm)

Đã gửi 24 February 2009 - 06:20 PM

Một ưu điểm của font kiểu xược mà bọn Kết Cấu Sư nhà em very khoái là nó có thể gõ được ký hiệu thép gai (fi 2 gạch) bằng %%G hoặc ký tự ` (bên trái phím số 1)
Font Unicode hoặc TCVN nhìn thì đẹp nhưng lại không có ký hiệu đó --> thật thiệt thòi!!!

Bác Jin ơi.Em làm như bác dạy mà không viết được fi hai gạch.Em dùng romans.bác chỉ bảo cặn kẽ em với.
  • 0
Only dead fish go with the stream!

#92 lequanghoang

lequanghoang

    biết pan

  • Members
  • Pip
  • 8 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 10 May 2009 - 05:42 PM

Các bro cho em hỏi Cad 2006 type tiếng việt bằng việtkey thế nào ạ.em tìm mọi cách mà không được(trừ font ventada)
-Xin cảm ơn


Làm ơn cho em hỏi làm thế nào để biết font bị lỗi của bản vẽ hiện hành là font gì ạ?
Thêm cái nữa là font nào thì copy vào hệ thống ,font nào thì copy vào cad ạ?
(Em hiện đang dùng cad 2008,file bị lỗi là 2004).Rất mong được các anh giúp đỡ.
  • 0

#93 boomba1412

boomba1412

    biết zoom

  • Members
  • Pip
  • 11 Bài viết
Điểm đánh giá: 2 (bình thường)

Đã gửi 11 May 2009 - 07:42 PM

Có thêm một chú ý về tiếng việt:
Theo tôi thấy, hiện tại đa số anh em vào cadviệt là dân miền Bắc, hay sử dụng font shx (VD: vnsimli.shx hoặc vntime.shx...) với bảng mã TCVN3. Và Engine 2 của Việt key chỉ phù hợp với bảng mã nay.

Tôi làm việc trong SG, môi trường sử dụng bảng mã VNI sử dụng font vn_vni.shx. Các engine của vietkey không có tác dụng với bảng mã VNI dùng trong môi trường AutoCAD. Cách duy nhất gõ tốt bảng mã VNI là dùng lệnh DDTEXTED.

Chú ý với các font shx này: hoàn toàn có thể kết hợp với bigfont để gõ theo kiểu xươc. :mellow: Thêm nữa, nếu mở 1 bản vẽ mà ko có mấy font xươc kia, dùng luôn font này thay cho font đó tất nhiên gắn bigfont nữa thế là bản vẽ lại đọc tôt.

Có vài chữ về AutoCAD 2007. Cad2k7 hỗ trợ hoàn toàn tiếng viêt. Bà con có thể gõ Unicode, TCVN3, VNI bằng bất kỳ loại font nào, ttf hay shx đều đươc. Do vậy, máy bà con đủ mạnh thì chơi luôn Cad2k7 cho đỡ bị phiền toái :mellow:

ai trả lời giùm tôi với?????? 1+1 =???
hic hic quên khoong học toán
  • 0

#94 tdtr

tdtr

    Chưa sử dụng CAD

  • Members
  • Pip
  • 2 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 20 May 2009 - 11:31 AM

Chào các bạn trên diễn đàn CadViet.
Tôi đang sử dụng Cad2004 và có lỗi như thế này:
Bình thường tôi dùng lệnh ED để đánh hoặc sửa chữ trong bản vẽ và trong cửa sổ Edit Text sẽ hiển thị tiếng Việt có dấu như mình đánh, nhưng thời gian gần đây tôi sử dụng cách này thì khi đánh tiếng Việt có dấu trong cửa sổ Edit Text không hiển thị tiếng Việt có dấu nữa mà toàn hiển thị các kiểu chữ "loằng ngoằng" đọc không ra, tuy nhiên khi thực hiện xong và trở về cửa sổ CAD thì vẫn đọc được tiếng Việt. Điều này gây rất nhiều bất tiện trong quá trình vẽ.
Để sửa lỗi này thì phải làm thế nào, mong các bạn trên diễn đàn chỉ giúp.
Thanks!
  • 0

#95 duongsatdn

duongsatdn

    biết lệnh adcenter

  • Moderator
  • PipPipPipPipPipPipPip
  • 1657 Bài viết
Điểm đánh giá: 761 (tốt)

Đã gửi 20 May 2009 - 02:37 PM

Chào các bạn trên diễn đàn CadViet.
Tôi đang sử dụng Cad2004 và có lỗi như thế này:
Bình thường tôi dùng lệnh ED để đánh hoặc sửa chữ trong bản vẽ và trong cửa sổ Edit Text sẽ hiển thị tiếng Việt có dấu như mình đánh, nhưng thời gian gần đây tôi sử dụng cách này thì khi đánh tiếng Việt có dấu trong cửa sổ Edit Text không hiển thị tiếng Việt có dấu nữa mà toàn hiển thị các kiểu chữ "loằng ngoằng" đọc không ra, tuy nhiên khi thực hiện xong và trở về cửa sổ CAD thì vẫn đọc được tiếng Việt. Điều này gây rất nhiều bất tiện trong quá trình vẽ.
Để sửa lỗi này thì phải làm thế nào, mong các bạn trên diễn đàn chỉ giúp.
Thanks!

Vụ này thì đành bó tay thôi bạn ạ. Cách tốt nhất là sống chung với nó, hoặc cài bộ CAD mới hơn.
  • 0

#96 Nguyen Hoanh

Nguyen Hoanh

    biết lệnh adcenter

  • Moderator
  • PipPipPipPipPipPipPip
  • 4106 Bài viết
Điểm đánh giá: 4495 (đỉnh cao)

Đã gửi 20 May 2009 - 06:40 PM

Chào các bạn trên diễn đàn CadViet.
Tôi đang sử dụng Cad2004 và có lỗi như thế này:
Bình thường tôi dùng lệnh ED để đánh hoặc sửa chữ trong bản vẽ và trong cửa sổ Edit Text sẽ hiển thị tiếng Việt có dấu như mình đánh, nhưng thời gian gần đây tôi sử dụng cách này thì khi đánh tiếng Việt có dấu trong cửa sổ Edit Text không hiển thị tiếng Việt có dấu nữa mà toàn hiển thị các kiểu chữ "loằng ngoằng" đọc không ra, tuy nhiên khi thực hiện xong và trở về cửa sổ CAD thì vẫn đọc được tiếng Việt. Điều này gây rất nhiều bất tiện trong quá trình vẽ.
Để sửa lỗi này thì phải làm thế nào, mong các bạn trên diễn đàn chỉ giúp.
Thanks!

Bạn thử chụp màn hình và upload file của bạn lên diễn đàn được không?
  • 0

#97 ktsk80

ktsk80

    biết lệnh erase

  • Members
  • PipPipPip
  • 107 Bài viết
Điểm đánh giá: 27 (tàm tạm)

Đã gửi 20 May 2009 - 07:44 PM

Mình dùng font arial trên labtop định ghi kí hiệu fi (alt + 0248) mà chỉ nghe máy phát ra tiếng kêu boong boong mà không hiện ra chữ. Ai giúp mình với , ai giúp mình với
  • 0
Tớ nẫu đây ! Khà khà

#98 221184

221184

    biết pan

  • Members
  • Pip
  • 6 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 21 May 2009 - 11:03 AM

ông nào biết lỗi bản cad của tôi không thể dùng file in có đuôi là .ctb mà nó chỉ có .stb
xin các bac chỉ giúp
Duyduyen@gmail.com
  • 0

#99 ali33

ali33

    Chưa sử dụng CAD

  • Members
  • Pip
  • 1 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 22 May 2009 - 10:06 AM

Tôi đang xài Cad2K9 HĐH Vista 64Bit, potay với tiếng việt cả 2 fần mềm VietKey 2007, Vietkey 2000, Unikey 4.0...

Tất cả bãng vẽ đều đọc được tiếng việt, nhưng không thể gõ, Bạn gõ đc xin bạn hướng dẫn dùm, thanks !!!


Tôi cũng không thể gõ tiếng Việt trong CAD2010, windows 7 64bit. Liệu có phải lỗi giống bạn tambeo? Lỗi nào là do CAD hay do HĐH 64bit nhỉ?
  • 0

#100 amsbett

amsbett

    Chưa sử dụng CAD

  • Members
  • Pip
  • 1 Bài viết
Điểm đánh giá: 0 (bình thường)

Đã gửi 01 June 2009 - 01:52 PM

help me!

mọi người ui! cho hỏi trong CAD khi font là ROMANS1 thì dùng bộ gõ nào vậy? Mình tìm mãi mà chẳng thấy!:s_big:
  • 0