Chuyển đến nội dung
Diễn đàn CADViet
lon ton

Sao em dùng lệnh Bo mà không được?

Các bài được khuyến nghị

Em dùng lệnh BO để tạo Pline một số đối tượng kín.

Nhưng chỉ 1 số thực hiện được còn 1 số thì không, nó báo lỗi là:

 

KhongBOdc.jpg

 

Em nghi là do có Z ở đây?

Vậy em phải làm gì để BO được và nếu do Z thì làm thế nào để loại bỏ hết Z được?

(em mới tham gia DĐ nên chưa được và tìm được hết các topic,

nếu có hỏi trùng lặp thì các bác thông cảm nhé)

Thanks!

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Em dùng lệnh BO để tạo Pline một số đối tượng kín.

Nhưng chỉ 1 số thực hiện được còn 1 số thì không, nó báo lỗi là:

 

 

Em nghi là do có Z ở đây?

Vậy em phải làm gì để BO được và nếu do Z thì làm thế nào để loại bỏ hết Z được?

(em mới tham gia DĐ nên chưa được và tìm được hết các topic,

nếu có hỏi trùng lặp thì các bác thông cảm nhé)

Thanks!

Do bạn chỉ đưa ảnh lên mà không đưa file dwg nên không biết có phải do Z không.

Muốn đưa z về 0 thì bạn vào phần download của diển đàn (phía trên ấy) vào phần autolisp load lisp là các đối tượng có z khác 0 về 0 Rồi dùng nó là được.

  • Vote tăng 1

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Do bạn chỉ đưa ảnh lên mà không đưa file dwg nên không biết có phải do Z không.

Muốn đưa z về 0 thì bạn vào phần download của diển đàn (phía trên ấy) vào phần autolisp load lisp là các đối tượng có z khác 0 về 0 Rồi dùng nó là được.

Cảm ơn bác nhiều nhé, em sẽ thử ngay đây!

(Nhưng bác có link của lisp dó không ^_^ em đang vừa làm vừa tìm này)

Thui bác à, em tìm thấy rùi!

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Do bạn chỉ đưa ảnh lên mà không đưa file dwg nên không biết có phải do Z không.

Muốn đưa z về 0 thì bạn vào phần download của diển đàn (phía trên ấy) vào phần autolisp load lisp là các đối tượng có z khác 0 về 0 Rồi dùng nó là được.

Tình hình là em vẫn không BO bằng Pl được dù đã dùng lisp bác cho?

Em up file lên bác xem thử giúp em:

http://www.cadviet.com/upfiles/Khong_BO_dc.dwg

Cảm ơn bác Duy nhiều nhé!

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Tình hình là em vẫn không BO bằng Pl được dù đã dùng lisp bác cho?

Em up file lên bác xem thử giúp em:

http://www.cadviet.com/upfiles/Khong_BO_dc.dwg

Cảm ơn bác Duy nhiều nhé!

Đúng là mình cũng không hiểu được. Nhưng bạn bo thành đối tượng REGION thì có vấn để gì không? Nó vẫn đo được diện tích mà.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Đúng là mình cũng không hiểu được. Nhưng bạn bo thành đối tượng REGION thì có vấn để gì không? Nó vẫn đo được diện tích mà.

Hì, bác mà không hiểu thì em sao hiểu được??!

Vấn đề của em ntn:

Em đang phải tách từng thửa đất trong đó để cho và bảng sơ họa thửa đất

(theo cái QĐ 18/2008 đáng ghét của UBND TP Hà Nội)

Hình vẽ sơ họa của thửa đất đó phải có đường thể hiện ranh giới vài thửa đất liền kề.

Vậy cho nên em cần copy cả ranh giới các thửa bên cạnh rồi offset thửa cần vẽ sơ họa ra rồi extrim bớt đi.

Nhưng đối tượng region lại không offset được.

Tuy nhiên đọc trên diễn đàn em cũng có 1 cách làm với việc như sau:

1. chuyển tất cả các thửa đất thành region (bằng lện REG)

2. chuyển tất cả region thành pline

(lisp của bác Ssg: http://www.cadviet.com/forum/index.php?sho...amp;#entry47197 )

3. copy các thửa đất cần sơ họa và các thửa lân cận vào bản sơ họa rồi offset ra rồi extrim.

Có điều là khi offset khó chọn đối tượng pline cần vì có nhiều pline chồng lên nhau,

hơn nữa em muốn biết thêm cách khác đơn giản hơn để áp dụng nếu cách kia gặp trục trặc.

Mà chắc bác biết cái cảm gáic muốn làm gì đó mà không thể làm được khó chịu lắm chứ??!

Cảm ơn bác nhiều!

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Bác tắt ký hiệu số thửa có dạng hình thoi kia đi là hatch bình thường.Nếu để ý kỹ bác sẽ thấy cái block đó gồm nhiều nét chồng nhau.Bo sẽ bị lỗi.Hoặc bác tắt block đó đi,hoặc chỉnh sửa block đó lại.

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác
Bác tắt ký hiệu số thửa có dạng hình thoi kia đi là hatch bình thường.Nếu để ý kỹ bác sẽ thấy cái block đó gồm nhiều nét chồng nhau.Bo sẽ bị lỗi.Hoặc bác tắt block đó đi,hoặc chỉnh sửa block đó lại.

Cảm ơn nhé, mình làm được rồi! ^_^

Chia sẻ bài đăng này


Liên kết tới bài đăng
Chia sẻ trên các trang web khác

Tạo một tài khoản hoặc đăng nhập để nhận xét

Bạn cần phải là một thành viên để lại một bình luận

Tạo tài khoản

Đăng ký một tài khoản mới trong cộng đồng của chúng tôi. Điều đó dễ mà.

Đăng ký tài khoản mới

Đăng nhập

Bạn có sẵn sàng để tạo một tài khoản ? Đăng nhập tại đây.

Đăng nhập ngay


×